using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[gG](?:[oO0]|\(\)|\[]|<>){2}[gG][LlI][eE3]";
string input = @"google
g()()GI3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}