$re = '/[gG](?:[oO0]|\(\)|\[]|<>){2}[gG][LlI][eE3]/m';
$str = 'google
g()()GI3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);