package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[gG](?:[oO0]|\(\)|\[]|<>){2}[gG][LlI][eE3]`)
var str = `google
g()()GI3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}