#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^\w])df\."
Local $sString = "asdf.wakawaka asdf.waka df.waka [df.waka (df.waka _df.waka {df,waka"
Local $sSubst = "$1kkk\."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)