re = /([^\w])df\./
str = 'asdf.wakawaka asdf.waka df.waka [df.waka (df.waka _df.waka {df,waka'
subst = '$1kkk\\.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result