// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^\w])df\.").unwrap();
let string = "asdf.wakawaka asdf.waka df.waka [df.waka (df.waka _df.waka {df,waka";
let substitution = "$1kkk\\.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}