using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+(улица|проспект)(.+|)\,";
string input = @"Россия, Красноярск, улица Партизан а Железняка, 40Б, Апарт Отель Парк Сити";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}