re = /.+(улица|проспект)(.+|)\,/m
str = 'Россия, Красноярск, улица Партизана Железняка, 40Б, Апарт Отель Парк Сити'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end