$re = '/.+(улица|проспект)(.+|)\,/m';
$str = 'Россия, Красноярск, улица Партизана Железняка, 40Б, Апарт Отель Парк Сити';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);