$re = '/^[A-Z0-9ČŠŽĐ](?:[A-Z0-9 ČŠŽĐ\-:;_\'"]{0,40}[A-Z0-9ČŠŽĐ])?$/i';
$str = 'It\'s a payment - for the bike';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);