re = /^[A-Z0-9ČŠŽĐ](?:[A-Z0-9 ČŠŽĐ\-:;_'"]{0,40}[A-Z0-9ČŠŽĐ])?$/i
str = 'It\'s a payment - for the bike'
# Print the match result
str.match(re) do |match|
puts match.to_s
end