import re
regex = re.compile(r"^[A-Z0-9ČŠŽĐ](?:[A-Z0-9 ČŠŽĐ\-:;_'\"]{0,40}[A-Z0-9ČŠŽĐ])?$", flags=re.IGNORECASE)
test_str = "It's a payment - for the bike"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")