import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Stable tag\\: [3]\\.[0].([1]|[2]|[3]|[4]|[5]|[6]|[7])|[3]\\.[0]$";
final String string = "Stable tag: 4.1.5.3\n"
+ "Stable tag: 11.0.5.3\n"
+ "Stable tag: 23.1.5.3\n"
+ "Stable tag: 13.0.1\n"
+ "Stable tag: 13.0\n"
+ "Stable tag: 2.0.1\n"
+ "Stable tag: 3.0.21.4.2\n"
+ "Stable tag: 3.0\n"
+ "Stable tag: 3.0.111.32\n"
+ "Stable tag: 1.0.1.3\n\n";
final String subst = "3.0.13";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}