use strict;
my $str = 'Stable tag: 4.1.5.3
Stable tag: 11.0.5.3
Stable tag: 23.1.5.3
Stable tag: 13.0.1
Stable tag: 13.0
Stable tag: 2.0.1
Stable tag: 3.0.21.4.2
Stable tag: 3.0
Stable tag: 3.0.111.32
Stable tag: 1.0.1.3
';
my $regex = qr/Stable tag\: [3]\.[0].([1]|[2]|[3]|[4]|[5]|[6]|[7])|[3]\.[0]$/mip;
my $subst = '3.0.13';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";