const regex = /Stable tag\: [3]\.[0].([1]|[2]|[3]|[4]|[5]|[6]|[7])|[3]\.[0]$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Stable tag\\: [3]\\.[0].([1]|[2]|[3]|[4]|[5]|[6]|[7])|[3]\\.[0]$', 'gmi')
const str = `Stable tag: 4.1.5.3
Stable tag: 11.0.5.3
Stable tag: 23.1.5.3
Stable tag: 13.0.1
Stable tag: 13.0
Stable tag: 2.0.1
Stable tag: 3.0.21.4.2
Stable tag: 3.0
Stable tag: 3.0.111.32
Stable tag: 1.0.1.3
`;
const subst = `3.0.13`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);