using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+\d+\s*\(?\d{3,4}\)?\s*\d{2,3}[ -]?\d{2}[ -]?\d{2}";
string input = @"+38 911 994 1104
+38 911 994 1104";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}