$re = '/\+\d+\s*\(?\d{3,4}\)?\s*\d{2,3}[ -]?\d{2}[ -]?\d{2}/m';
$str = '+38 911 994 1104
+38 911 994 1104';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);