package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+\d+\s*\(?\d{3,4}\)?\s*\d{2,3}[ -]?\d{2}[ -]?\d{2}`)
var str = `+38 911 994 1104
+38 911 994 1104`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}