using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=@[a-z]+,)\s+(?![a-z]+\s+\[[a-z]+\])|(?<=(@[a-z]+,\s[a-z]+))\s+(?=\[[a-z]+\])";
string substitution = @"";
string input = @"@fsfasfsdf, <<<
@sdfJKfsd, <<<
@asdjsdhasLAKJA, <<<
@A, <<<<
@noMatchInThisLine,<<<<<
@sdasdsad, dsajkdlasdfasd [fsadsd]<<<<<<<
@ noMatchInThisLine, <<<<
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}