const regex = /(?<=@[a-z]+,)\s+(?![a-z]+\s+\[[a-z]+\])|(?<=(@[a-z]+,\s[a-z]+))\s+(?=\[[a-z]+\])/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=@[a-z]+,)\\s+(?![a-z]+\\s+\\[[a-z]+\\])|(?<=(@[a-z]+,\\s[a-z]+))\\s+(?=\\[[a-z]+\\])', 'gmi')
const str = `@fsfasfsdf, <<<
@sdfJKfsd, <<<
@asdjsdhasLAKJA, <<<
@A, <<<<
@noMatchInThisLine,<<<<<
@sdasdsad, dsajkdlasdfasd [fsadsd]<<<<<<<
@ noMatchInThisLine, <<<<
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);