import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=@[a-z]+,)\\s+(?![a-z]+\\s+\\[[a-z]+\\])|(?<=(@[a-z]+,\\s[a-z]+))\\s+(?=\\[[a-z]+\\])";
final String string = "@fsfasfsdf, <<<\n"
+ "@sdfJKfsd, <<<\n"
+ "@asdjsdhasLAKJA, <<<\n"
+ "@A, <<<<\n"
+ "@noMatchInThisLine,<<<<<\n"
+ "@sdasdsad, dsajkdlasdfasd [fsadsd]<<<<<<<\n"
+ "@ noMatchInThisLine, <<<<\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}