using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Average).*?(?<=<\/sup>)([0-9.]{5})";
string input = @"</sup>73.00</span> </td> </tr> <tr class=""highlight""> <td><span class=""data_lbl"">Average</span></td> <td> <span class=""data_data""><sup></sup>86.06</span> </td> </tr> <tr> <td><span class=""data_lbl"">Current Price</span></td> <td> <span class=""data_data""><sup> </sup>83.20</span> </td> </tr> </tbody> </table> </div> </div> <!--data-module-name=""quotes.module.researchratings.Module""--> </div> <div class=""column at8-col4 at16-col4 at12-col6"" id=""adCol""> <div intent in-at4units-prepend=""#adCol"" in-at8units-prepend=""#adCol"" in-at12units-prepend=""#adCol";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}