import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Average).*?(?<=<\\/sup>)([0-9.]{5})";
final String string = "</sup>73.00</span> </td> </tr> <tr class=\"highlight\"> <td><span class=\"data_lbl\">Average</span></td> <td> <span class=\"data_data\"><sup></sup>86.06</span> </td> </tr> <tr> <td><span class=\"data_lbl\">Current Price</span></td> <td> <span class=\"data_data\"><sup> </sup>83.20</span> </td> </tr> </tbody> </table> </div> </div> <!--data-module-name=\"quotes.module.researchratings.Module\"--> </div> <div class=\"column at8-col4 at16-col4 at12-col6\" id=\"adCol\"> <div intent in-at4units-prepend=\"#adCol\" in-at8units-prepend=\"#adCol\" in-at12units-prepend=\"#adCol";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}