# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=Average).*?(?<=<\/sup>)([0-9.]{5})"
test_str = "</sup>73.00</span> </td> </tr> <tr class=\"highlight\"> <td><span class=\"data_lbl\">Average</span></td> <td> <span class=\"data_data\"><sup></sup>86.06</span> </td> </tr> <tr> <td><span class=\"data_lbl\">Current Price</span></td> <td> <span class=\"data_data\"><sup> </sup>83.20</span> </td> </tr> </tbody> </table> </div> </div> <!--data-module-name=\"quotes.module.researchratings.Module\"--> </div> <div class=\"column at8-col4 at16-col4 at12-col6\" id=\"adCol\"> <div intent in-at4units-prepend=\"#adCol\" in-at8units-prepend=\"#adCol\" in-at12units-prepend=\"#adCol"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.