$re = '/(^\S+).*/m';
$str = 'along ad.向前;和…一起;一同 prep. 沿着;顺着
aloud ad. 大声地
already ad. 已经
also ad. 也
although conj. 虽然,尽管
altogether ad. 总共
always ad. 总是;一直;永远
am v. be的人称形式之一 📷
a.m./A.M. 📞 n. 午前,上午
America * n. 美国;美洲';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;