// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\S+).*").unwrap();
let string = "along ad.向前;和…一起;一同 prep. 沿着;顺着
aloud ad. 大声地
already ad. 已经
also ad. 也
although conj. 虽然,尽管
altogether ad. 总共
always ad. 总是;一直;永远
am v. be的人称形式之一 📷
a.m./A.M. 📞 n. 午前,上午
America * n. 美国;美洲";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}