# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\S+).*"
test_str = ("along ad.向前;和…一起;一同 prep. 沿着;顺着 \n"
"aloud ad. 大声地 \n"
"already ad. 已经 \n"
"also ad. 也 \n"
"although conj. 虽然,尽管 \n"
"altogether ad. 总共 \n"
"always ad. 总是;一直;永远 \n"
"am v. be的人称形式之一 📷\n"
"a.m./A.M. 📞 n. 午前,上午\n"
"America * n. 美国;美洲")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.