using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"card>.*?\D?(?<card>\d{16})\<card";
string input = @"card>1234567890129787<card
card> this is so and so info 1234567890129787<card
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}