// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)card>.*?\D?(?<card>\d{16})\<card").unwrap();
let string = "card>1234567890129787<card
card> this is so and so info 1234567890129787<card
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}