$re = '/card>.*?\D?(?<card>\d{16})\<card/m';
$str = 'card>1234567890129787<card
card> this is so and so info 1234567890129787<card
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);