using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=: ),?.*?(?=[A-Z]*?:\W|$)";
string input = @"FREEZE: (1 of a liquid 3:4) be turned into ice or another solid as a result of extreme cold.
""in the winter the milk froze""
PULL: a force drawing someone or something, in a particular: direction or course of action;
WAY OF PATH: a road, track, path, or street for traveling along.
RADIO: communicate or send a message by radio!.
COUNTER TOP: (1:3) a flat surface for working on, especially in a kitchen:
and possible outdoor kitchen
PATIO: a paved outdoor area adjoining a house
SEA SPRAY: Sea spray are aerosol particles formed from the ocean, mostly by ejection into Earth's atmosphere by bursting bubbles at the air-sea interface: Sea spray contains both organic matter and inorganic salts that form sea salt aerosol
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}