import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=: ),?.*?(?=[A-Z]*?:\\W|$)";
final String string = "FREEZE: (1 of a liquid 3:4) be turned into ice or another solid as a result of extreme cold.\n"
+ "\"in the winter the milk froze\"\n"
+ "PULL: a force drawing someone or something, in a particular: direction or course of action; \n"
+ "WAY OF PATH: a road, track, path, or street for traveling along. \n"
+ "RADIO: communicate or send a message by radio!.\n"
+ "COUNTER TOP: (1:3) a flat surface for working on, especially in a kitchen:\n"
+ "and possible outdoor kitchen\n"
+ "PATIO: a paved outdoor area adjoining a house\n"
+ "SEA SPRAY: Sea spray are aerosol particles formed from the ocean, mostly by ejection into Earth's atmosphere by bursting bubbles at the air-sea interface: Sea spray contains both organic matter and inorganic salts that form sea salt aerosol\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}