import re
regex = re.compile(r"(?<=: ),?.*?(?=[A-Z]*?:\W|$)", flags=re.DOTALL)
test_str = ("FREEZE: (1 of a liquid 3:4) be turned into ice or another solid as a result of extreme cold.\n"
"\"in the winter the milk froze\"\n"
"PULL: a force drawing someone or something, in a particular: direction or course of action; \n"
"WAY OF PATH: a road, track, path, or street for traveling along. \n"
"RADIO: communicate or send a message by radio!.\n"
"COUNTER TOP: (1:3) a flat surface for working on, especially in a kitchen:\n"
"and possible outdoor kitchen\n"
"PATIO: a paved outdoor area adjoining a house\n"
"SEA SPRAY: Sea spray are aerosol particles formed from the ocean, mostly by ejection into Earth's atmosphere by bursting bubbles at the air-sea interface: Sea spray contains both organic matter and inorganic salts that form sea salt aerosol\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")