const regex = /`([a-zA-Z_0-9]+)`/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('`([a-zA-Z_0-9]+)`', 'g')
const str = `CREATE TABLE \`table_name01\``;
const subst = `[$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);