$re = '/`([a-zA-Z_0-9]+)`/';
$str = 'CREATE TABLE `table_name01`';
$subst = "[$1]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;