// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"`([a-zA-Z_0-9]+)`").unwrap();
let string = "CREATE TABLE `table_name01`";
let substitution = "[$1]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}