package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[[:alnum:]]+(?:_\d+){2}(?:\.\d+)?(?:\|[[:alnum:]]+(?:_\d+){2}(?:\.\d+)?)*$`)
var str = `lkas32kj_123_3.21
lkas32kj_123_3.21|l3kj_12_0.21|123e_4_32.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}