use strict;
my $str = 'lkas32kj_123_3.21
lkas32kj_123_3.21|l3kj_12_0.21|123e_4_32.1';
my $regex = qr/^[[:alnum:]]+(?:_\d+){2}(?:\.\d+)?(?:\|[[:alnum:]]+(?:_\d+){2}(?:\.\d+)?)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}