$re = '/^[[:alnum:]]+(?:_\d+){2}(?:\.\d+)?(?:\|[[:alnum:]]+(?:_\d+){2}(?:\.\d+)?)*$/m';
$str = 'lkas32kj_123_3.21
lkas32kj_123_3.21|l3kj_12_0.21|123e_4_32.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);