const regex = /^(?!0+(?:\.0+)?$)\d+(?:\.\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!0+(?:\\.0+)?$)\\d+(?:\\.\\d+)?$', 'gm')
const str = `0
1
100
99909
1.2
111.77700
0.0
00.00
0.1
0.0001
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}