$re = '/^(?!0+(?:\.0+)?$)\d+(?:\.\d+)?$/m';
$str = '0
1
100
99909
1.2
111.77700
0.0
00.00
0.1
0.0001
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);