re = /^(?!0+(?:\.0+)?$)\d+(?:\.\d+)?$/m
str = '0
1
100
99909
1.2
111.77700
0.0
00.00
0.1
0.0001
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end