package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s@]+@(?:[^\s.]+\.)*canada\.ca$`)
var str = `joe@canada.ca
joe@it.canada.ca
joe.smith@business.canada.ca
joe@visitcanada.ca`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}