re = /^[^\s@]+@(?:[^\s.]+\.)*canada\.ca$/m
str = 'joe@canada.ca
joe@it.canada.ca
joe.smith@business.canada.ca
joe@visitcanada.ca'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end