$re = '/^[^\s@]+@(?:[^\s.]+\.)*canada\.ca$/m';
$str = 'joe@canada.ca
joe@it.canada.ca
joe.smith@business.canada.ca
joe@visitcanada.ca';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);