use strict;
my $str = 'Not captured
Inline: Front :: Back
Not captured
Multiline: Front ::
- Back - First line
+ Back - Second line
* Back - Third line
<!--ID: 1686385186868--> Obsidian_to_Anki ID line is not captured
Multiline: Front :: Back
- First line
+ Second line
* Third line
ThisIsAlsoCaptured';
my $regex = qr/(.+) ::((?:.|\n.{4}(?<!<!--))+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}