import Foundation
let pattern = #"(.+) ::((?:.|\n.{4}(?<!<!--))+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Not captured
Inline: Front :: Back
Not captured
Multiline: Front ::
- Back - First line
+ Back - Second line
* Back - Third line
<!--ID: 1686385186868--> Obsidian_to_Anki ID line is not captured
Multiline: Front :: Back
- First line
+ Second line
* Third line
ThisIsAlsoCaptured
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)