$re = '/(.+) ::((?:.|\n.{4}(?<!<!--))+)/m';
$str = 'Not captured
Inline: Front :: Back
Not captured
Multiline: Front ::
- Back - First line
+ Back - Second line
* Back - Third line
<!--ID: 1686385186868--> Obsidian_to_Anki ID line is not captured
Multiline: Front :: Back
- First line
+ Second line
* Third line
ThisIsAlsoCaptured';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);