#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Field\d+:"
Local $sString = "Field1:" & @CRLF & _
"Something" & @CRLF & _
"Field2:" & @CRLF & _
"Something" & @CRLF & _
"Field3:" & @CRLF & _
"Field4:" & @CRLF & _
"Field1:" & @CRLF & _
"Something" & @CRLF & _
"Field2:" & @CRLF & _
"Field3:" & @CRLF & _
"Something" & @CRLF & _
"Field4:" & @CRLF & _
"Something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")