re = /Field\d+:/m
str = 'Field1:
Something
Field2:
Something
Field3:
Field4:
Field1:
Something
Field2:
Field3:
Something
Field4:
Something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end